Exception in YouTube Player

Jan 27, 2015 at 8:12 PM
I use your wonderful package for WP8.1SL projects since several month but since several days i have the "no_video_urls_found" exeption.

I understand Youtube have change the API to access videos. Could you help me ?

Last version used :)

Best Regards
Jan 27, 2015 at 8:33 PM
Edited Jan 27, 2015 at 8:34 PM
I've been using the library myself for several months now and everything worked fine till today. As of today videos won't play. I haven't debugged yet but i have the bad feeling like i may get the exact same exception. Maybe there is a way to solve the problem after the changes? maybe rsuter has an answer.
Jan 27, 2015 at 9:29 PM
Hi,
I use the youtub api yesterday on windows phone, it's worked very well but today when I use YouTube.GetVideoUriAsync() it's return always null

I don't know why ?
mytoolkit Account api google api refused ?
Jan 27, 2015 at 10:15 PM
Good evening.

I'm experiencing the same thing. :(

The YouTube API must've changed somehow, and MyToolkit hasn't yet coped with those changes.

Can the people behind the toolkit please have a look at this?

Thank you.
Jan 27, 2015 at 10:42 PM
Edited Jan 27, 2015 at 10:43 PM
Same here. As of now my apps that are heavily tied to MyToolkit to get the YouTube URI to play are down including one in the store. :(
Jan 27, 2015 at 11:18 PM
Ok, I tried var youTubeUris = await YouTube.GetUrisAsync(YouTubeVideoId);
And this returns zero length YouTubeUri array.

I hope Rico would fix it.
Jan 28, 2015 at 12:05 AM
I have found the solution but you need to recompile the package. If you want i can give it :)
Jan 28, 2015 at 12:20 AM
Sure, please. You are a lifesaver. :)
Jan 28, 2015 at 12:22 AM
Hi
Could you please provide.
Thanks
Ram Uppugunduri aka govinda11

Sent from Windows Mail

Jan 28, 2015 at 12:34 AM
In the file : Shared\Multimedia\YouTube.cs

Replace "url_encoded_fmt_stream_map\": \"(.?)\"" by "url_encoded_fmt_stream_map\":\"(.?)\"" (Remove space after ':\')

You can do the same thing in this line "adaptive_fmts\": \"(.*?)\""

Just a workaround for waiting the official patch ;)
Jan 28, 2015 at 12:35 AM
You’re awesome.
Thank you.
Ram

Sent from Windows Mail

Jan 28, 2015 at 1:55 AM
Edited Jan 28, 2015 at 3:10 AM
Looks like it's not working for me ��

I take my word back. Your solution works fine. Thanks again. :)
Jan 28, 2015 at 3:26 AM
i'm sorry
but, can anyone teach me or give me a link on how to recompile the package?
I already download the package, but there are no shared folder
so, please, can anyone help me?
Jan 28, 2015 at 3:43 AM
Click on SOURCE CODE Tab above. Then choose Download there and download the latest source.
Coordinator
Jan 28, 2015 at 8:18 AM
Edited Jan 28, 2015 at 8:22 AM
Hi everybody, thanks for discussing the problem and coming up with solutions.

It seems that there are currently two problems:
  • The reading of the mp4 links (discussed here)
  • Problems while generating signatures.
I just submitted a patch, please checkout the code and try if it works for you. If everything works for now, ill release a new NuGet package version.
Jan 28, 2015 at 8:26 AM
I confirm that the patch fixed things at least for me.
Jan 28, 2015 at 8:28 AM
I confirm the latest commited code works for me too. Thanks Rico.
Jan 28, 2015 at 9:35 AM
This Solves the problem for me:
Replace "url_encoded_fmt_stream_map\": \"(.?)\"" by "url_encoded_fmt_stream_map\":\"(.?)\"" (Remove space after ':\')

You can do the same thing in this line "adaptive_fmts\": \"(.*?)\""

Thank you very much CordoWeb.. !! :)
Coordinator
Jan 28, 2015 at 5:45 PM
Hello everybody,
The NuGet package version 2.3.25 is now ready.
Please update your project and report back if it works for you.
Jan 28, 2015 at 6:06 PM
Thanks a lot for your very good job ... for free ;)
Best Regards from France.
Jan 28, 2015 at 7:18 PM
Rico
thanks a lot my friend. yes, this update is working. thanks a lot for your effort.
Ram
Sent from Windows Mail