Has Youtube Uri changed since about May 2014?

Sep 23, 2014 at 12:46 AM
My app was working fine in May 2014 but haven't used it in a while. Just noticed it is not working now. It returns a uri (example below) using Mytoolkit methods. But even if I try to open it in Firefox, it will not open. Anything change in the Uri creation code lately? I have not downloaded the lastest version of Mytoolkit. There are no dates on the change log versions on the Downloads page so it's tough to tell what has shipped since May. Thanks for any advice.

Example Uri
https://r9---sn-ab5l6nez.googlevideo.com/videoplayback?mm=31&fexp=916601,924639,927622,930666,931983,932404,934030,936117,938644,946023,947209,950200,950616,952302,953801,954700,955401&key=yt5&upn=4pbV4eIJ7Ok&sparams=gcr,id,initcwndbps,ip,ipbits,itag,mime,mm,ms,mv,ratebypass,source,upn,expire&initcwndbps=1425000&ms=au&itag=18&ratebypass=yes&source=youtube&ip=2601:6:6500:594:1982:9816:c642:8e6&mime=video/mp4&ipbits=0&mt=1411424880&id=o-AJHgzWUa9FrfukvNSCP5m8fJJ0I3vQfvScmkaQaYDcrR&sver=3&expire=1411446527&mv=m&gcr=us&signature=53E03E8F8D4B48706FBDAC0E808FC8B16CE1F53136E.785D7A2B76601B8376DFA2D528DD15D8088EB1E61E7
Coordinator
Sep 23, 2014 at 7:04 AM
Hi,

I think there was a problem with signature generation which has been improved in july... You should try the newest bits...
Sep 23, 2014 at 11:33 AM
Ok thanks Rico, I'll give it a shot.
You gave me these links back in May for the Mytoolkit Youtube source code.
Are these updated to the latest code level?

https://xp-dev.com/svn/mytoolkit/Shared/Multimedia/YouTube.cs
https://xp-dev.com/svn/mytoolkit/Shared/Multimedia/YouTubeQuality.cs
Coordinator
Sep 23, 2014 at 12:03 PM
Its now developed on the git repo not svn anymore, see

http://mytoolkit.codeplex.com/SourceControl/latest
Coordinator
Sep 23, 2014 at 12:03 PM
Edited Sep 23, 2014 at 12:25 PM
You should use the library using nuget...
Sep 23, 2014 at 12:54 PM
Ok thanks. Found it. I'll get the source from there.

Unfortunately, I can't use nuget. I'm still on Visual Studio 2010 4.0.3 -- VS2010 does not support .Net 4.5 which causes NUget to throw an exception.
Sep 23, 2014 at 6:23 PM
Rico, thanks for your help. Working perfect again. And thanks again for this awesome library!! :-)
Coordinator
Sep 23, 2014 at 6:29 PM
Great. If you like the project, please follow and review it..
Sep 25, 2014 at 10:32 PM
I can't seem a url from the following anymore:

https://www.youtube.com/watch?v=9PUfkAJVvMs
Sep 25, 2014 at 11:47 PM
Hmm. I can't get it to load with my app either. I wonder if it's because it has "Partner rating TV-14"? If I use a browser to load it, YouTube says you need to login to prove you are 14+ years old to see the video.
Coordinator
Sep 26, 2014 at 7:00 AM
I cant even play it on the website - video not available.
Sep 26, 2014 at 11:37 AM
Maybe the video is restricted by country. I can view it on the youtube website (in the US) AFTER i log into my youtube account.
Coordinator
Sep 26, 2014 at 11:40 AM
To avoid logging in, the class uses the useragent of the google bot to scrap the page. This way it worked even if you had to login on the regular site (eg age restriction). Maybe they changed this and now this workaround does not work anymore?
Sep 26, 2014 at 12:38 PM
Yeah, Looking at the YouTube Data API (v3) Revision History, there were a lot of "rating" api changes this past year. But I really know nothing about the api, so this is beyond my skill set.
https://developers.google.com/youtube/v3/revision_history
Coordinator
Sep 26, 2014 at 12:44 PM
The yt classes do not use the data api. They parse the html page...
Sep 26, 2014 at 10:12 PM
I attempted the same url using an oAuth2 token from an account with age permissions and it still doesn't work. I don't think the rating is the issue unless I'm doing the oAuth2 token incorrectly.
Sep 26, 2014 at 10:29 PM
The YT web page also shows country restrictions.

meta itemprop="isFamilyFriendly" content="False">
   meta itemprop="regionsAllowed" content="AS,CA,GU,MP,PR,UM,US,VI">