YouTube Streams Video and Audio url separated problem

Jul 31, 2014 at 3:17 AM
Hi all,

First all, this project and toolkit is awesome!
It help me a lot.


But 2 days ago, I got a big problem, when I using this toolkit to get YouTube stream

When I using MyToolkit.Multimedia.YouTube.GetUrisAsync(videoId); method,
I found High-Resolution(ex:1080p), It video stream didn't contain audio track.

But still can get audio url separately.

So I got two source url, one is Video, another one is Audio.

And I tried sync them to play by using Microsoft PlayerFrame Work MediaPlayer controller.
But it seem like can't get 2 different source at same time.


If i put two MediaPlayer, and using timer to sync these player's position, it didn't work for me.
My platform is Universal App which hole framework running async.

This way cause sound choppy...

My problem seem like this:http://mytoolkit.codeplex.com/discussions/468771

But at least I didn't know how crisdorya to solve this problem.


Thanks!
Coordinator
Aug 12, 2014 at 7:02 PM
Did you solve the problem?
Aug 13, 2014 at 3:37 AM
rsuter wrote:
Did you solve the problem?
Didn't..., I tried a lot of way but can't work.

Any method using timer or dispatcher to sync two player isn't work in Windows Store App.
Coordinator
Aug 13, 2014 at 10:33 AM
Have you tried to contact crisdorya? It seems that he found a solution..
Aug 18, 2014 at 3:18 AM
rsuter wrote:
Have you tried to contact crisdorya? It seems that he found a solution..
I tired to contact crisdorya, waiting reply.

But crisdorya's solution I tried to implement, but got problem in this discussion descriptive.