a reference to a higher version or incompatible issue while adding reference to my wp8 project

May 12, 2014 at 6:25 AM
Hi,
i downloaded the MyToolkit package, extracted and trying to add wp8 dlls . it showing a reference to a higher version or incompatible error message. please give me solution
Coordinator
May 13, 2014 at 9:54 PM
Have you tried to install the library using nuget.org?
May 14, 2014 at 4:05 AM
Thank you for the help. I try to install them but the following problems occurred.

PM> Install-Package MyToolkit.Extended
Attempting to resolve dependency 'MyToolkit (≥ 2.2.3.0)'.
Attempting to resolve dependency 'Microsoft.Bcl.Async (≥ 1.0.166)'.
Install-Package : The 'Microsoft.Bcl.Async 1.0.168' package requires NuGet client version '2.8.1' or above, but the current NuGet
version is '2.7.40911.287'.
At line:1 char:1
  • Install-Package MyToolkit.Extended
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : NotSpecified: (:) [Install-Package], NuGetVersionNotSatisfiedException
    • FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
Coordinator
May 14, 2014 at 6:30 AM
What version of visual studio are you using? You need to install the newest nuget extension, download it on nuget.org.