Some YouTube Media Cannot Play.

Jun 25, 2013 at 2:57 PM
Edited Jun 26, 2013 at 3:30 AM
Hi.

Recently some Youtube Media Cannot Play at MyToolkit.Multimedia.YouTube.Play method.
My Phone appears message "Sorry, we can't play this file on your phone."

for example
videoid: Uondd8GKQqQ can't play ( perhaps, new update and HD-quality )
however, videoid: CR9bybqMnKQ can play ( update date is older )

The majority of recently added HD-quality video show such symptoms.

that's all
I want to fix it.
thank you.


[environment]
I use Nokia Lumia 820 latest update version WP8.
region+Language : South Korea, Korean and United States, English Tested

MyToolkit.* : latest updated -1.17.0(2013-06-25)
Windows Phone Toolkit : latest updated

Windows 8 pro K x64
VS.NET 2012 Express for WP8
Jul 1, 2013 at 11:02 PM
I am also seeing this on win8. most of the music videos stopped playing (from vevo). other videos works. thanks for your help!
Jul 2, 2013 at 9:22 AM
Hi,

I figured problem out for this alerting.

It is due to the YouTube video source changes.

YouTube video source stream(.MP4)s are becoming real stream(many many sound file groups + many many only picture stream).

so, i read to YouTube API Docuements about iframe API and Windows WebView Notification for Windows 8, Windows Phone 7,8.
then I concluded, only solution for this alerting is use webview(webbrowser) and HTML5 Youtube player that controled by "windows.externel.notify script"

Hope that helps for You, Other features to be modified before...