This project is read-only.

YouTube.GetVideoUriAsync doesn't work on Lumia 520

Mar 23, 2014 at 3:28 PM

I have the same problem with thread, but some bite differences are my code was tested successfully for Lumia 1320, 1020, 625, but Lumia 520. I got "The remote server returned an error: NotFound" exception any time I have ran the GetVideoUriAsync method.

Is this a problem with Google back-end changes. If not, could you give me any solution to help to resolve this.

Many thanks,
Mar 23, 2014 at 3:39 PM
Have you tried it in the WP sample app?
Can you give me some YouTube IDs to test?
Mar 23, 2014 at 3:47 PM
Mar 23, 2014 at 5:32 PM
I have tried it yet, I cannot build the sample solution for WP8 app. But I almost sure that my code run well on other Lumia devices except Lumia 520. Could you help to explain why it happen? I used Fiddler to catch request / response to Youtube, but I have only seen the request from phone and no response.
Mar 23, 2014 at 5:43 PM
I dont know whats the problem. I think its a problem with this specific device... Whats different to the other devices (e.g. language, internet connection, os version)? Have you tried to reset it?
Apr 19, 2014 at 11:32 AM
I am also having the same problem with 520. On other devices it runs very well. I tried other youtube apps in 520 and they are playing video. So is there any problem or any other sdk?
Apr 19, 2014 at 11:38 AM
I dont have a 520 to test it. You need to download the source code and debug on your device. If you can provide more info about what is causing the problem i may help you..
Apr 19, 2014 at 12:04 PM
I am getting this error

Message=The remote server returned an error: NotFound.


MyToolkit.Multimedia.YouTube.GetVideoUriAsync() method
Apr 19, 2014 at 1:01 PM
Sorry to say, I am wrong and its not the problem with 520. Actually date and time of the phone is not correct which causes some certificate problem. That's why its not working on phone but on emulator.
Apr 19, 2014 at 1:02 PM
Ok, thx for reporting back