This project is read-only.

Problem with GetVideoUriAsync on winRT

Dec 19, 2012 at 10:25 AM

So, a few days ago the above code just didn't worked anymore

   public async void setVideo(string strVideo)
        {
            var yt = await YouTube.GetVideoUriAsync("pLbY5ykcGb0");

            myvideo.Source = yt.Uri;
       }

 

I was using version 1.6.0 but updated to 1.70 and later 1.8.0 and still don't show the video, the funny thing is that if a copy the Uri and throw at the browser the video appears, it didn't play but shows a screen of the video, while in my app don't show nothing.

Anyone has any suggestion on what can I do?

 

Thanks,

Dec 19, 2012 at 10:30 AM
Edited Dec 19, 2012 at 10:32 AM

The retrieved video Uri plays without problems in my Firefox. Maybe you have a broken Win8 installation / some codecs missing?

Dec 19, 2012 at 11:19 AM

Well, I tried the URI in another notebook and it played normally...So I guess is a problem on my developer machine, I'm gonna try on another notebook with win8 later.

Thanks!